卡特前线指挥官多少钱:筹码公式2(转载)

来源:百度文库 编辑:学校大全网 时间:2021/09/26 05:35:52
1.【地量换手】
穿越筹码:ABS(WINNER(CLOSE)-WINNER(OPEN))*100,STICK,COLORDDDDFF;
换手比率:VOL/CAPITAL*100,STICK,COLORFF0099;
地量换手:1/换手比率*100,STICK,COLORRED,LINETHICK3;
A1:=LLV(HIGH,240);
MYP:=100*(CLOSE-A1)/A1;
A2:=REF(HHV(CLOSE,240),1);
B2:=REF(LLV(CLOSE,240),1);
RPY:=100*(CLOSE -B2)/(A2-B2);
A3:=1.1*CLOSE;
B3:=0.9*CLOSE;
ASR:=100*(WINNER(A3)-WINNER(B3));
A4:=WINNER(CLOSE);
A5:=DMA(A4,VOL/CAPITAL);
B4:=DMA(VOL,VOL/CAPITAL)/CAPITAL;
A6:=100*VOL/CAPITAL;
B6:=100*(WINNER(CLOSE)-REF(WINNER(CLOSE),1));
A7:=ABS(B6/A6);
CYA:A4/B4*50,COLOR00FF00;
CYB:EMA(A4/B4*50,34),COLORFF00FF;
CYC1:A5/B4*50,COLORRED;
IF(RPY<75 AND MYP<30 AND ASR>60 AND 穿越筹码>=24 AND (VOL/CAPITAL*100)<=3 AND C>=O,地量换手+200,0),STICK,LINETHICK3,COLORFF00FF;
IF(A7>30 AND (VOL/CAPITAL*100)<=3,地量换手,0),STICK,LINETHICK2,COLORWHITE;

筹码穿透率:=B6/A6;
IF(筹码穿透率>10 AND CLOSE/REF(CLOSE,1)>=1.05 AND 换手比率<=3,地量换手+200,0),STICK,LINETHICK3,COLORBLUE;
IF(RPY<75 AND MYP<30 AND ASR>60 AND 穿越筹码>=24 AND (VOL/CAPITAL*100)<=3 AND CCYD:WINNER(CLOSE)/(VOL/CAPITAL),COLORYELLOW,STICK,LINETHICK4;
2.【筹码密集】
VAR1:=MA(CLOSE,30);
VAR2:=VAR1+2*STD(CLOSE,30);
VAR3:=(VAR2-VAR1)/VAR1*100;
VAR4:=COST(15)+(COST(85)-COST(15))/2;
VAR5:=COST(5)+(COST(95)-COST(5))/2;
VAR6:=VAR4+VAR4*N1/100;
VAR7:=VAR4-VAR4*N1/100;
VAR8:=VAR5+VAR5*N2/100;
VAR9:=VAR5-VAR5*N2/100;
VARA:=COST(15)>=VAR7 AND COST(85)<=VAR6;
筹码密集: IF(DATE<1330501,COST(5)>=VAR9 AND COST(95)<=VAR8,0), COLORSTICK,COLORRED;
高度密集: IF(DATE<1330501,0.999*筹码密集 AND VARA AND VAR3<=10,0), CIRCLEDOT,COLORYELLOW;
{n1(2,120,6),n2(2,120,13)}
3.【筹码分布】
获利99 := MA(COST(99 ),5);
获利80:=MA(COST(80),5);
均线5日:= MA(C,5);
获利20:=MA(COST(20),5);
获利1 :=MA(COST(1),5);
A1:=(获利99-获利80)/获利80*100;
A2:=(获利80-获利20)/获利20*100;
AA3:=(获利20-获利1)/获利1*100;
A4:=IF(A2<10 ,100 ,0 );
高密集:A4, COLORSTICK; {VOLSTICK;}
A5:=IF(A2<15 ,50 ,0 );
中密集:A5, COLORSTICK;
A6:=IF(A2<20 ,25 ,0 );
低密集:A6, COLORSTICK;
密集度:A2;
4.可以看见主力与散户筹码的拥有量的公式
VAR1:=1;
VAR2:=1/WINNER(CLOSE);
VAR3:=MA(CLOSE,13);
VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=30-VARB;
主力: (100-VARA)*VAR1,COLOR0099FF;
散户: MA(WINNER(CLOSE*0.95)*100,3)*VAR1,COLORYELLOW;
新庄: (30-IF(VAR2>5,IF(VAR2<100,VAR2,VAR4-10),0))*VAR1,COLORGREEN,LINETHICK6,POINTDOT ;
VARD:=散户>VAR4;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
STICKLINE(VARD,VAR4,散户,5,0),COLORWHITE;
{STICKLINE(1,新庄,100,1,0),COLORGREEN;}
STICKLINE(VAR20,0,80,5,0),COLORRED,LINETHICK3 ;
100,COLORGREEN ,LINETHICK2 ;
0,COLORYELLOW ,LINETHICK2 ;
中线: 15,COLORBLUE ,LINETHICK2 ;
量能看盘
量能:VOL,VOLSTICK;
量能1:(((SMA(MAX((CLOSE - EMA(REF(((LOW + HIGH) / 2),2),1)),0),13,1) / SMA(ABS((CLOSE - EMA(REF(((LOW + HIGH) / 2),2),1))),13,1)) * EMA(VOL,13)) * 3),LINETHICK2;
量能2:(((SMA(MAX((CLOSE - SMA(REF(CLOSE,2),2,1)),0),34,1) / SMA(ABS((CLOSE - SMA(REF(CLOSE,2),2,1))),34,1)) * SMA(VOL,13,1)) * 2.8),LINETHICK2;
量能3:(((SMA(MAX((CLOSE - SMA(REF(CLOSE,2),2,1)),0),68,1) / SMA(ABS((CLOSE - SMA(REF(CLOSE,2),2,1))),68,1)) * SMA(VOL,34,1)) * 2.8),LINETHICK2;
量比:DYNAINFO(17),LINETHICK0,COLORFFFFFF;
换手:((VOL / CAPITAL) * 100),LINETHICK0,COLORFF0000;
6.【量能MACD】
DIFF : EMA((SMA(AMOUNT,10,1)/100000000)*CLOSE/(MA(REF(CLOSE,1),5)),12) - EMA((SMA(AMOUNT,10,1)/100000000)*CLOSE/(MA(REF(CLOSE,1),5)),26);
DEA : EMA(DIFF,9);
MACD : 2*(DIFF-DEA), COLORSTICK;
筹码(改自大智慧原公式)更直观!
获利盘:winner(c);
浮筹10%:(winner(c*1.1)-winner(c*0.9))/winner(hhv(h,0))*100 ,stick,color006400,linethick2;
pr:(获利盘-ref(获利盘,1))/v*capital*10 ,volstick;
浮筹比例(Active Stock Rate) asr:
算法:
收盘价上下10%的筹码所占的比例。
用法:
和移动筹码分布配合使用;
具体用法参看大智慧教材《超级移动筹码》;

穿透率(Penetrate Rate)
算法:
今日收盘价的获利比例减去昨日收盘价的获利比例除以换手率。
用法:
较高的穿透率说明筹码锁定较好;
要和移动筹码分布配合使用;
详细用法参看大智慧教材《超级移动筹码》。


{吸筹}

Var2:=REF(LOW,1);
Var3:=SMA(ABS(LOW-Var2),3,1)/SMA(MAX(LOW-Var2,0),3,1)*100;
Var4:=EMA(IF(CLOSE*1.3,Var3*10,Var3/10),3);
Var5:=LLV(LOW,30);
Var6:=HHV(Var4,30);
Var7:=IF(MA(CLOSE,58),1,0);
Var8:=EMA(IF(LOW<=Var5,(Var4+Var6*2)/2,0),3)/618*Var7;
Var9:=IF(Var8>100,100,Var8);
吸筹:STICKLINE(Var9>-120,0,Var9,6,1),colorf00ff0;
成本底.价格底.量能底.选股底 资金流量(源码)
成本底.价格底.量能底.选股底

Var2:DMA(EMA(C,5),SUM(VOL,8)/3/CAPITAL);
Var3:FORCAST(CLOSE,21);

Var4:=DMA(C,V/MA(V,3)/3);
Var5:=DMA(C,V/MA(V,37)/37);
Var6:=Var4<0.884*Var5;
Var7:=WINNER(C*1.22)-WINNER(C)<0.16;
成本底:=Var6 and Var7;
价格底:=L量底:=MA(AMOUNT,180)*MA(V,3)>1.33*MA(AMOUNT,3)*MA(V,180);
选底:(成本底 or 价格底 or 量底) and C<1.025*Var3 and c<0.98 and v/capital>MA(v/capital,5)*0.50 and c/cost(17)<0.871
,LINETHICK0;
DRAWICON(选底,L,10);
DRAWTEXT(filter(选底,5),L,'→77%成功'),colorwhite;
DRAWICON(cross(Var3,MA(C,3)) and Var3>ref(Var3,1),H*1.03,2);
DRAWICON(成本底 AND 价格底 and C<1.025*Var3 and c<0.98 and v/capital>MA(v/capital,5)*0.50 and c/cost(17)<0.871,L,1);
DRAWICON(量底 AND 价格底 and C<1.025*Var3 and c<0.98 and v/capital>MA(v/capital,5)*0.50 and c/cost(17)<0.871,L,8);
DRAWICON(成本底 AND 量底 and C<1.025*Var3 and c<0.98 and v/capital>MA(v/capital,5)*0.50 and c/cost(17)<0.871,L,15);


资金流量(源码)


资金流量(源码)

量:=VOL;
额:=AMOUNT/10000000;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE主卖:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE换手:VOL/CAPITAL*100;
流通盘:CAPITAL/1000000;

流入资金:ma(主买,4);
流出资金:ma((0-主卖),4);
bb:=(主买+主卖);

STICKLINE(流入资金>流出资金,流入资金,流出资金,6,0),COLORRED;
STICKLINE(流入资金<流出资金,流出资金,流入资金,6,0),COLORGREEN;
柱状换手率(源码)
换手:VOL/CAPITAL*100,LINETHICK0,COLORWHITE;

{换手零点五以下: }
STICKLINE(换手>0,换手,0,7,0),COLORGRAY;
STICKLINE(换手>0.5,换手,1,7,0),COLORGRAY;
{介于零点五到一点五:}
STICKLINE(换手>0.5,换手,1,7,0),COLORCYAN;
STICKLINE(换手>1.5,换手,3,7,0),COLORCYAN;
{介于一点五到三: }
STICKLINE(换手>1.5,换手,3,7,0),COLORGREEN;
STICKLINE(换手>3,换手,5,7,0),COLORGREEN;
{介于三到五: }
STICKLINE(换手>3,换手,5,7,0),COLORYELLOW;
STICKLINE(换手>5,换手,7,7,0),COLORYELLOW;
{介于五到七:}
STICKLINE(换手>5,换手,7,7,0),COLORMAGENTA;
STICKLINE(换手>7,换手,9,7,0),COLORMAGENTA;
{大于七: }
STICKLINE(换手>7,换手,9,7,0),COLORRED;


SQ盈亏换手

SQ盈亏换手(个人版)
(VOL / (CAPITAL * WINNER(CLOSE))),stick,colorFF;
(0 - (VOL / (CAPITAL * (1 - WINNER(CLOSE))))),stick,colorcyan;

SQ盈亏换手(机构版)}
(VOL / (CAPITAL * WINNER(((AMOUNT / VOL) / 100)))),stick,colorFF;
(0 - (VOL / (CAPITAL * (1 - WINNER(((AMOUNT / VOL) / 100)))))),stick,colorcyan;
★老蔡★筹码
M1:EMA((100 * WINNER((CLOSE * (1 + (3 / 1000))))),89),LINETHICK1;
M2:EMA((100 * WINNER((CLOSE * (1 - (3 / 1000))))),13),LINETHICK1;
M3:EMA((100 * WINNER((CLOSE * 1.1))),73),LINETHICK1;
M4:EMA((100 * WINNER((CLOSE * 0.9))),37),LINETHICK1;
CD:(M2 - M1);
STICKLINE((CD >= 0),0,CD,2,0),COLOR3300FF;
STICKLINE((CD < 0),0,CD,2,0),COLORCC3300;
STICKLINE((M3 > M1),((M3 - M1) - 5),(M3 - M1),1,0),COLOR663300;
M5:(M3 - M1),COLORFF0000;
{IF(((M5 <= REF(M5,1)) AND (M3 >= REF(M3,1))),M5,DRAWNULL),LINETHICK3,COLORFF00FF;
IF((M1 < REF(M1,1)),M1,DRAWNULL),POINTDOT,LINETHICK1,COLOR808080;
IF((M1 >= REF(M1,1)),M1,DRAWNULL),LINETHICK3,COLORFFFFFF;
IF((M2 < REF(M2,1)),M2,DRAWNULL),POINTDOT,LINETHICK1,COLOR808080;
IF((M2 >= REF(M2,1)),M2,DRAWNULL),LINETHICK2,COLORFFFF00;
IF((M3 < REF(M3,1)),M3,DRAWNULL),POINTDOT,LINETHICK1,COLOR808080;
IF((M3 >= REF(M3,1)),M3,DRAWNULL),LINETHICK2,COLORFF00FF;
IF((M4 < REF(M4,1)),M4,DRAWNULL),POINTDOT,LINETHICK1,COLOR808080;
IF((M4 >= REF(M4,1)),M4,DRAWNULL),LINETHICK2,COLORFFFF00;}
探底筹码:=((1 / WINNER(CLOSE)) / 10);
触顶筹码:=((1 / (1 - WINNER(CLOSE))) / 10);
IF((探底筹码 > 100),100,0),LINETHICK1,COLORFF99FF;
IF(BETWEEN(探底筹码,50,100),50,0),LINETHICK1,COLORCC00FF;
IF(BETWEEN(探底筹码,20,50),20,0),LINETHICK1,COLOR9900CC;
IF(BETWEEN(探底筹码,5,20),5,0),LINETHICK1,COLOR660099;



主力成本轨道

主力成本轨道
A:=HHV(VOL,12);
高:IF((VOL = A),HIGH,REF(HIGH,BARSLAST((VOL = A)))),;
低:IF((VOL = A),LOW,REF(LOW,BARSLAST((VOL = A)))),;
STICKLINE((高AND 低),高,低,2,0),,COLORCCCCCC;
STICKLINE(((CLOSE > OPEN) OR ((CLOSE = OPEN) AND (CLOSE > REF(CLOSE,1)))),CLOSE,HIGH,0.1,0),,COLORFF0000;
STICKLINE(((CLOSE > OPEN) OR ((CLOSE = OPEN) AND (CLOSE > REF(CLOSE,1)))),OPEN,LOW,0.1,0),,COLORFF0000;
STICKLINE(((CLOSE > OPEN) OR ((CLOSE = OPEN) AND (CLOSE > REF(CLOSE,1)))),OPEN,CLOSE,7,0),,COLORFF0000;
STICKLINE(((CLOSE < OPEN) OR ((CLOSE = OPEN) AND (CLOSE <= REF(CLOSE,1)))),HIGH,LOW,0.1,0),,COLORFF0000;
STICKLINE(((CLOSE < OPEN) OR ((CLOSE = OPEN) AND (CLOSE <= REF(CLOSE,1)))),OPEN,CLOSE,7,0),,COLORFF0000;
HH:=高;
LL:=低;
CON1:=(((REF(CLOSE,2) <= REF(HH,2)) AND (REF(CLOSE,1) <= REF(HH,1))) AND (CLOSE > HH));
CON2:=(((REF(CLOSE,2) >= REF(LL,2)) AND (REF(CLOSE,1) >= REF(LL,1))) AND (CLOSE < LL));
DRAWICON((CON1 AND FILTER(CON1,5)),(LOW * 0.995),1),;
DRAWICON((CON2 AND FILTER(CON2,5)),(HIGH * 1.005),2),;
底部吸筹 主筹估算
Var2:=REF(LOW,1);
Var3:=SMA(ABS(LOW-Var2),3,1)/SMA(MAX(LOW-Var2,0),3,1)*100;
Var4:=EMA(IF(CLOSE*1.2,Var3*10,Var3/10),3);
Var5:=LLV(LOW,30);
Var6:=HHV(Var4,30);
Var7:=IF(LLV(LOW,58),1,0);
Var8:=EMA(IF(LOW<=Var5,(Var4+Var6*2)/2,0),3)/618*Var7;
Var9:=IF(Var8>100,100,Var8);
var5x:=llv(low,75);
var6x:=hhv(high,75);
var7x:=(var6x-var5x)/100;
var8x:=sma((close-var5x)/var7x,20,1);
vara:=3*var8x-2*sma(var8x,15,1);
{底部吸筹}
var26:=(close-llv(low,27))/(hhv(high,27)-llv(low,27))*100;
var28:=sma(var26,3,1);
波段王:=sma(var28,3,1);
STICKLINE(Var9>-150,0,Var9,3,0),colorff00ff;
底部吸筹指标: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100,color00ff00;
底部吸筹: STICKLINE(Var8,0,Var8,6,1),COLORred;
乖离线: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100,COLORffff00;
STICKLINE(CROSS(16.5,底部吸筹指标),40,0,4,0),colorf00ff0;
STICKLINE(CROSS(40,底部吸筹指标),40,0,4,0),colorf00ff0;
STICKLINE(CROSS(20,底部吸筹指标),40,0,4,0),colorf00ff0;
STICKLINE(CROSS(底部吸筹指标,-5.4) and (8+底部吸筹指标)*10>=29 and (100-vara)>49 and

(vara>sum(vara,20)/20 or 波段王>25),(8+底部吸筹指标)*(100-vara)/5,0,4,0),colorffffff;
先知: (CLOSE-LLV(LOW,40))/LLV(LOW,40)*100,COLORYELLOW;
主力线: (CLOSE-MA(LLV(LOW,40),40))/MA(LLV(LOW,40),40)*100,COLOR00ff00;
可能放量拉升: IF(CROSS(底部吸筹指标,-5.4),(8+底部吸筹指标)*10,0),colorffffff;
drawtext(CROSS(底部吸筹指标,-5.4) and (8+底部吸筹指标)*10>=29,15,'拉升'),color00eeaa;
drawtext(CROSS(16.5,底部吸筹指标),10,'注意'),colorred;
drawtext(CROSS(40,底部吸筹指标),15,'注意'),colorred;
drawtext(CROSS(20,底部吸筹指标),20,'注意'),colorred;



=============
主筹估算

主筹估算:EMA(WINNER(C)*70,1),LINETHICK2,COLORRED;
散筹估算:EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,1),LINETHICK1,COLORGREEN;
筹码锁定:散筹估算-主筹估算,COLORFFBB00; 筹码活动:0,COLORFFAAFF;
STICKLINE(筹码锁定>0,筹码锁定,散筹估算,5,0),COLORFFAAFF;
STICKLINE(筹码锁定<=0,0,散筹估算,5,0),COLOR009900;
STICKLINE(筹码锁定>0,0,筹码锁定,5,0),COLORFFBB00;
STICKLINE(筹码锁定<0,0,筹码锁定,5,0),COLORFFBB00;
STICKLINE(筹码锁定<-50,-50,筹码锁定,5,0),COLORRED;
动态底部:EMA(IF(L<= LLV(L,480),SMA(ABS(L-REF(L,1)),480,1)/SMA(MAX(L-REF(L,1),0),480,1),0)*5,1),COLORYELLOW;
STICKLINE(动态底部>0,0,动态底部,5,0),COLORYELLOW;
主筹估算,LINETHICK2,COLORRED;
DRAWICON(CROSS(主筹估算,散筹估算),散筹估算,1);
DRAWICON(CROSS(主筹估算,筹码锁定),主筹估算-0.2,2);

实战必胜(主图)
上线:=sma(c,6.5,1);
下线:=sma(c,13.5,1);
上线1:=sma(c,3,1);
下线1:=sma(c,8,1);
STICKLINE(上线>下线 , 上线,下线 ,2.5, 0),colorred,linethick2;
stickline(下线>上线,上线,下线,2.5,0),coloryellow,linethick2;
DRAWTEXT( cross(上线,下线),low *0.98,'全仓买' ),Color00FFFF;
全仓买: cross(上线,下线);
drawtext(cross(下线1,上线1),h*1.02,'清仓'),Color80FF00;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
UPR:=BBI+3*STD(BBI,13);
DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,60);
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT( CROSS(82,RSI) , HIGH*1.02,'减仓') ,COLORff9966,linethick2;
A7:=(2*C+H+L)/4;
操作:MA(a7,5),linethick2;
操作1:=MA(a7,5)*1.03;
操作2:=MA(a7,5)*0.97;
Var1:LLV(a7,21);
Var2:HHV(a7,21);
SK:=EMA((A7-Var1)/(Var2-Var1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
DRAWTEXT(IF(count(close6/10 and vol>=1.5*ma(vol,5) and
count(sk>=sd,3) and ref(low,1)=LLV(Low,120),1,0),LOW*0.98,'买进') ,COLOR0099ff;
买进:sk>=sd;3;
DRAWTEXT(IF(count(close6/10 and
count(sk>sd,6) and ref(low,5)=LLV(Low,120) and ref(close>=open,4) and
ref(close>open,3) and REF(CLOSE>OPEN,2) AND   ref(open>close,1) and
open>ref(close,1),1,0),LOW*0.98,'买进') ,COLOryellow;
D:=MA(CLOSE,80)-MA(CLOSE,10)/3;
DRAWTEXT(if(CLOSEMA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE抄底: CLOSE 优化买点 副图 XX2:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
奇线: MA((CLOSE-XX2)/XX2,1),colorred;
买点1: IF(CROSS(奇线,0) AND LOW/REF(HIGH,1)<1.012,0.5,0), STICK,COLORWHITE;
买点2: IF(REF(奇线,2)=LLV(奇线,20) AND REF(奇线,2)<0.071 AND REF(奇线,2)REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1),0.5,0),COLORRED;
DRAWTEXT( 买点1>0,0.2 ,'神奇线'),COLORWHITE;
DRAWTEXT( 买点2>0,0.4 , '神奇线'),COLORyellow;

锁定筹码选股公式

通用源码:
A:=1.1*C;
B:=0.9*C;
B1:=100*(WINNER(A)-WINNER(B));
锁定筹码 :100-B1;
C1:=MA(C,13)明天买:IF(CROSS(锁定筹码,90)AND C1,60,0);
筹码锁定区:STICKLINE(锁定筹码>65 AND C1,锁定筹码-50,0,6,0);
锁定筹码不断上升与股价不断下跌形成底背离同时出红柱(可以出一个,也可以多个)的选股公式   用在飞弧上。

 

SCR筹码集中度指标

    筹码集中度,顾名思义就是指人(股东)均所持的股票多少在流通总股本中所占的分额。SCR筹码集中度指标反映的是股票集中程度的变化趋势,是一个追踪主力资金建仓与减仓的重要指标,也是股民选股与买进、卖出的股票的重要参考标准。其公式为: p1=100 A:=P1+(100-P1)/2; B:=(100-P1)/2; CC:=COST(A); DD:=COST(B); SCR: (CC-DD)/(CC+DD)*100/2。筹码集中度指标SCR在系统中一般设3个标准数值,流通总股本的多少不同,参考数值不一样。在此我把它统称为上中下三个数值。

    筹码集中度的评判原则:

    1.SCR线在下线以下,表示筹码很分散,主力资金已经抽走或者没有主力资金入住。对于这种股票我们不宜建仓,除非在股指超低,股票价值面很好,做长期的价值投资。

    2.SCR线在下线——中线区间,表明筹码集中度相对分散,同样表明主力迹象不明显,主要是散户在炒作。这个时候股价一般不会有大幅的拉升,因为筹码分散,拉升股价的成本大,力度要求高。在此区间,不宜建仓,观望最好。

    3.SCR从中线间上扬力穿上线,这是主力建仓迹象,应该高度关注,上扬的力度越大,主力建仓的迹象越明显。在此过程中股价也许下降,这是SCR线与股价的背离,此背离是主力建仓的重要标准。在此过程中散户,宜高度关注,不一定要跟进,等主力建仓完成,股价开始上升,就需强力建仓,主力为散户抬轿,散户不能太客气。

    4.SCR线上穿上位线后,一般SCR线有一个平滑的过程,该过程为主力拉升股价的过程,散户此时应该持股上涨。

    5.在上线以区间SCR线一旦开始下滑,表明主力开始获利出逃,此时股民应该高度关注,但是不一定立刻看空,主力出逃有一个过程,如果SCR线已经下穿20线并出现股票价格下跌,此时散户看空为妙。

    特别提醒:

    筹码集中度的指标反映的主力资金的有关情况,股民操作只能作为依据之一,具体操作需要结合其他指标和相关内容。在大牛市中,筹码集中度指标与股价的相关关系往往会失效。

筹码分析理论
前言:
概念:
股价走势循环周期的四个阶段:
A阶段:无穷成本均线由向下到走平;俗称筑底阶段;
B阶段:无穷成本均线由走平到向上;俗称拉升阶段,可称为上升阶段;
C阶段:无穷成本均线由向上到走平;俗称作头(顶)阶段;
D阶段:无穷成本均线由走平到向下;俗称派发阶段,可称作下降阶段;
对应筹码分布的特征:
    A阶段:筹码由分散到集中,发散度下降。
    B阶段:筹码由集中到分散,发散度上升。
    C阶段:筹码由分散到集中,发散度下降。
    D阶段:筹码由集中到分散,发散度上升。

股市里的终极真理:供给大于需求价格下跌,需求大于供给价格上涨。
而供求又最终对应于资金和筹码。至于其它什么基本面、消息、信心、技术等等,都只是间接地影响或反映股市的这一本质。股价运动的本质等于成交量背后的筹码运动状态。
筹码     供求力量的两方:资金和筹码.
在股市里的意义是明显不同的。对于资金,倾向于有行情就有资金这种说法。也就是说,有行情才是关键,这是中国股市中长期走势的主线。筹码,则是股市利益主体博弈的媒介,抓住了筹码这一关键,才有可能从本质上把握住股票的价格走势。因此,从博弈角度看,筹码,才是股市博弈的核心。
筹码论其实是一种还原:将所有的影响股市里供求的因素,全部还原成筹码,以及筹码背后所反映的力量、利益、争夺、控制集中、分散、转移、等等。所以我认为股市研究的核心应该是市场成本! 在熊市中现金为主,而在牛市中筹码的为王,股票获利无非是将手中的现金在低位转化成股票,再将股票在高位兑换为现金的过程,这是从另一角度上看,就是筹码的运动,主流资金就是筹码的搬运工,而筹码的成本就是关键,成本分析将成为技术分析中非常重要的一个分支。
主要功能与目的
1.判断成交密集区的筹码分布和变化。
2.判断行情发展中的重要阻力位与支撑位。
3.通过分析市场的变化,制定相应的操作策略。
筹码是股票博弈的核心,在牛市中筹码为王就是这个道理,谁掌握更多的筹码谁就将在未来的博弈中争取到主动权,谈到筹码应从以下几方面进行研究
一、筹码的成本
这是筹码的核心问题,市场中主流资金或绝大部分的筹码的成本对股票的走势起决定性作用,这里引入成本均线的概念,主要是反映市场的平均持筹成本的成本均线。
平均移动线与成本均线的区别。成本均线在计算中考虑了成交量的作用,并用神经网络方法解决了在计算时间内短线客反复买卖的问题,可以真实的反应最后的持股人的成本。5日、13日、34日成本均线分别代表5日、13日、34日的市场平均建仓成本。如某日13日成本均线为10.2元,表示13日以来买入该只股票的人平均成本为10.2元。无限长的成本均线则表示市场上所有的股票的平均建仓成本。
无穷成本平均线是最重要的成本均线。是市场牛熊的重要分水岭,就象价值曲线一样,股票价格始终围绕起上下一波动,这里又引出另一个概念,无穷成本均线的乘离率,也叫盈亏指标。
该指标反映投资者平均持色的盈亏,5.13日盈亏对短线操作有重大意义,而引物尤其是无穷BIAS才对中长期判断有决定性作用,这个指标在投资方案和思路中占有重要的地位,比如。什么叫超跌?跌倒什么份上差不多了?为什么有的股票跌连跌7.8个跌停仍不超跌?盈亏指标较好地解决了这些问题。
二、筹码分布的形态:密集与分散
筹码分布的运动:集中与发散
成交密集的区域,形成筹码峰,两峰之间的区域则形成谷,这是筹码分布的视觉形态,筹码的运动伴随筹码的集中与发散。必然伴随着筹码密集而形成峰。密集分为高位密集和低位密集。
任何一轮行情都将经历由低位换手到高位换手,再由高位换手到低位换手,筹码的运动过程是实现利润的过程。(当然也是割肉亏损的过程)
低位充分换手是完成吸筹阶段的标志,高位充分换手是派发阶段完成的标志。
成本密集是下一个阶段行情的准备过程,成本发散是行情的展开过程。
三、集中度
表明主要筹码堆积的主要区域的幅度,数值越大表示筹码集中的幅度越大,筹码就越分散,需要特别提醒的是,这个集中的意思,不等同于庄家控盘,与龙虎榜数据完全不是一个意思。
就目前而言,无法将其编成方案,只能通过一只一只股票的观察进行总结,得出的以下结果。
1。筹码集中度高的股票(10以下)的爆发力强,上涨或下跌的幅度比较大。
2.筹码集中度低的股票(尤其是20以上)的上涨力度明显减弱。
3.筹码的集中过程是下一阶段行情的准备过程,而发散过程是行情的展开过程。
需要强调:
1.不是只有集中,股票才会上涨。
2.达到集中,上涨的幅度增大。
3.不集中的股票,也会上涨。
四、活跃筹码
筹码分布能让我们看出别人持股成本的分布情况,是我们做成本分析时很有效的工具。我们仔细观察筹码分布的变化情况时,发现在股价附近的筹码是最不稳定的,也是最容易参与交易的,因为在股价附近的股票持有者,最经受不住诱惑,盈利的想赶快把浮动盈利换成实际盈利;被套的想趁着亏损得还少赶快卖掉,利用资金买另外的股票,把亏损赶快挣回来。而远离股价,在下方的筹码,由于有了一定的利润,持股信心会增强;在上方的筹码,由于被套太深而不愿割肉,所以在股价附近的筹码是最活跃的,而在股价上下,远离股价的筹码是不太活跃的。
活跃筹码就是反映股价附近的筹码占所有流通筹码的百分比。它的取值范围是从0到100,数值越大表示股价附近的活跃筹码越多,数值越小表示股价附近的活跃筹码越少。
活跃筹码的多少还可用来描述筹码的密集程度,如今天的活跃筹码的值是50,则表示在股价附近的筹码呈密集状态。如今天的活跃筹码的值是10,则表示在股价附近的筹码很少,大多数筹码都在远离股价的地方,获利很多,或者亏损很多。
活跃筹码的数值很小时是很值得注意的一种情况。比如,一只股票经过漫长的下跌后,活跃筹码的值很小(小于10),大部分筹码都处于被套较深的状态,这时多数持股者已经不愿意割肉出局了,所以这时候往往能成为一个较好的买入点;再比如:一只股票经过一段时间的上涨,活跃筹码很小(小于10),大部分筹码都处于获利较多的状态,如果这时控盘强弱的值较大(大于20),前期有明显的庄股特征,总体涨幅不太大,也能成为一个较好的买入点。所以,在股价运行到不同的阶段时,考虑一下活跃筹码的多少,能起到很好的辅助效果。
五、投机策略
短线资金或小盘资金(3个月内,2000万以内)以方案为主,中线资金和大盘资金的投机策略,将有所变化。以下是两类思路请您给出建议和意见。谢谢!

1.逆势操作
股票跌穿单密集峰,如果股价超跌而原单密集峰并没有被消耗,行情将发生V形反转,反转第一目标位在原密集峰处。
*股价跌穿原单峰密集;
*股价下跌的速度较快;
*下跌至超跌区原单峰密集仍完好存在;
*活跃筹码越少越好。
*5cm01(上档筹码)越小越好。
超跌V形反转确认后即时跟进;或无穷乖离达到-30越跌越买。
股价反弹至原单峰密集区域出场观望。
2.顺势操作
A低位突破
股价经较长时间的整理,移动成本分布在低位形成单峰密集,同时股价放量突破单峰密集是一轮上升行情的征兆。
*一轮上涨行情的充分条件是移动成本分布形成低位峰密集;
*单峰的密集程度越大筹码换手越充分,上攻行情的力度越大;
*单峰低位高度密集意味着股价的上升空间彻底打开;
*要从历史的走势中确认相对低位;
*单峰密集形成的时间越长其可靠性越强;“横多长竖多高”就是这原理。
*突破必须有大成交量的确认;
*突破的股价有效穿越密集峰并创出近期新高。
*活跃筹码一般在85以上为好。
B高位突破
股票经一轮升势后在高位形成单峰密集,如果股价再次突破高位峰密集将是新一轮升势的开始。
*股价经一轮升幅形成高位单峰密集;
*股价的突破一定要创出近期历史新高;
*要历史地研判高位密集的成因;
*将股价回落击穿高位密集峰设定为止损位;
*以短线的策略操盘;
*谨防假突破。
投资成功关键在于:使用方法的哲学思想正确,交易系统的一致性,铁的纪律.

 

 

 


            筹码分布选股法


              
              什么是筹码分布呢?我个人认为是:股票在交易过程中,在不同价位所堆积的股数。从获利盘来看,它的区间为0%--100%。那么庄家是在什么位置建仓的?是在低位建的仓。那么什么是低位呢?是10%以下,或20%以下,还是50%以下?
              
              庄家和散户是在博弈的。往往散户认为的低位,庄家是不会建仓的。也就是说,底是庄家做出来的,而不是散户。那么庄家又是在低位建的仓,如何知道庄家的建仓成本是多少?
              
              1、首先定义低位:把获利盘50%以下定义为低位。
              
              为什么不把10%以下定义为低位?想一想,庄家拿了10%的筹码能不能把这股票做上去?回答是NO。50%太高了吧?不高,因为在股票下跌的时候,散户很少做买卖的动作。而当股价上升了一段时间,散户就活跃起来了,有买的,有卖的,这时,庄家就可以在震荡中吃到散户的筹码。没有一定的获利盘,庄家到那里去吃筹码呢?
              
              2、再定义底:底是走出来的。只有出现了低点,在以后的日子里不再创新低,那才叫底。如何找出来呢?可以在分析家中写这么一个指标:
              
              E:=LLV(L,250)=L;{一年中最低价的位置}
              E1:=BARSLAST(E);{求得一年中最低价的位置到现在的周期}
              底:IF(E1>40,1,0);
              
              底做的时间越长,底部越可靠,股市里有句谚语:"横的越长,涨的越高"(我给它加个条件,是在低位),说的就是做底的意思。为什么选40(只要40天以上不创一年的新低的都有庄)呢?因为现在是牛市,在牛市里庄家也来个做底半年甚至一年,那牛市早就过了。到了熊市,可以将它调大一点。
              
              只要把从底部到现在的时间里获利盘50%以下的平均价求出来,就可以知道庄家的成本了。对,但这是股市,股市是涨涨跌跌的,是有时放量有时缩量的,或是平盘的。总的来说,股市是非线性的。您得把它的放量和缩量也考虑进去。
              
              大家知道换手放量的时候,几天或10几天,换手就是100%,缩量的时候,几个月换手也没有100%。那照前面的周期算,如果是放量的时候还有点准,如果是缩量的时候一点用也没有。
              
              打个比方:如果一个股的流通盘是100股,今天成交1股,明天成交3股,后天成交2股,大后天成交50股,再大大后天成交50股。那成本是依那一天为准(不考虑庄家对敲的问题)?回答当然是最后2天的,而不是这5天的平均价。这就是股市的非线性。那么就要考虑这个问题,因成交量在股市里起着非常大的作用。
              
              那么,如何求这个"非线性周期"呢?因为流通盘是一定的,如果成交量大,那么把所有的流通盘换一次手所需的时间就短,反之,则时间就长。这个周期是变动的,也就是"非线性"的。可以用分析家软件编一个公式:
              
              A:=SUMBARS(V ,CAPITAL);{累计换手=100%的周期}
              
              那如何知道庄家的成本呢?前面已经说过,在底部区域里获利盘50%以下的平均价即为庄家的成本。庄家在获利盘50%以下的这个区域里,在10%或20%下吃的多,40%或50%之间吃的少。给它们分配比例,给10%以下的最多,给20%以下的少一点,依次递减。这样就可以得到庄家的成本了。
            用分析家软件编个主图公式,就可以在主图上看到庄家的成本了。公式如下:
              
              A:=SUMBARS(V ,CAPITAL*1);{累计换手=100%的周期}
              A1:=SUM(COST(10),A)/A;{在A周期里获利10%的平均价}
              A2:=SUM(COST(20),A)/A;{在A周期里获利20%的平均价}
              A3:=SUM(COST(30),A)/A;{在A周期里获利30%的平均价}
              A4:=SUM(COST(40),A)/A;{在A周期里获利40%的平均价}
              A5:=SUM(COST(50),A)/A;{在A周期里获利50%的平均价}
              感谢对我们的支持,大家共同提高~5*A1+4*A2+3*A3+2*A4+A5)/15,
            CIRCLEDOT,COLORRED;{求出庄家成本}
              
              把公式做在主图上。公式中的5,4,3,2,是分配的比例系数。
              
              当然,某些股票有特大利好时,庄家来不及慢慢的吸筹,就不知道它的成本了。对,但1000多个股票有几个是这样的,一年中又有几个?我说的是个普遍性的东西。
              
              现在把上面的四个问题加在一起,再加一个条件:收盘价上穿成本线。我们就认为庄家要启动了。公式如下:选股公式
              
              A:=SUMBARS(V,CAPITAL*1);
              A1:=SUM(COST(10),A)/A;
              A2:=SUM(COST(20),A)/A;
              A3:=SUM(COST(30),A)/A;
              A4:=SUM(COST(40),A)/A;
              A5:=SUM(COST(50),A)/A;
              E:=LLV(L,250)=L;
              E1:=BARSLAST(E);
              感谢对我们的支持,大家共同提高~:=(5*A1+4*A2+3*A3+2*A4+A5)/15;
              感谢对我们的支持,大家共同提高~1:IF(CROSS(C,感谢对我们的支持,大家共同提高~) AND E1>=40,1,0 );
              
              做好了这个公式,可以用盘中预警监视A股板块。这样就可以做短线了。也可以用它选股后保存在一个板块里,以后多加注意。
              
              当然,也可以将上面的公式做成主图指标,这样便于分析。公式如下:
              
              A:=SUMBARS(V ,CAPITAL*1);{累计换手=100%的周期}
              A2:=SUM(COST(20),A)/A;{在A周期里获利20%的平均价}
              A1:=SUM(COST(10),A)/A;{在A周期里获利10%的平均价}
              A3:=SUM(COST(30),A)/A;{在A周期里获利30%的平均价}
              A4:=SUM(COST(40),A)/A;{在A周期里获利40%的平均价}
              A5:=SUM(COST(50),A)/A;{在A周期里获利50%的平均价}
              E:=LLV(L,250)=L;{一年中最低价的位置}
              E1:=BARSLAST(E);{求得一年中最低价的位置到现在的周期}
              感谢对我们的支持,大家共同提高~:(5*A1+4*A2+3*A3+2*A4+A5)/15,
            CIRCLEDOT,COLORRED;{求出启动点的价位}
              感谢对我们的支持,大家共同提高~1:STICKLINE(CROSS(C,感谢对我们的支持,大家共同提高~) AND E1>=40
            ,O ,C ,5 ,0 ),COLOR00FFFF;{得到启动点}
              
              点评:
              
              ◆假如没有庄家,在股市中COST(50)以下买的优于COST(50)以上买的,由于有庄家刻意炒作,所以股价在COST(50)以下跌多涨少,在COST(50)以上涨多跌少,结果散户就偏偏中了圈套。所谓的短线就是在庄家短暂出货时的帮工而已,有人得了工钱,有人上了贼船。所以买股如果要兼顾时间短、获利快又较安全,就在股价回探COST(50)附近向上拐头时买入,放量不能突破COST(90)卖出。如突破,则等跌破COST(90)卖出。
              
              画蛇添足:
              
              没有庄家,在股市中COST(50)以下买的优于COST(50)以上买的
              --获利压力小就好。
              
              有庄家刻意炒作,所以在股价在COST(50)以下跌多涨少
              --打压吸货嘛。
              
              有庄家刻意炒作,在COST(50)以上涨多跌少
              --获利盘大都是庄家的,涨当然是主旋律。
              
              在股价回探COST(50)附近向上拐头时买入
              --趋势看涨,获利盘又不大。
              
              放量不能突破COST(90)卖出
              --人人饱赚,个个想溜,快跑吧!
              
              ◆如果再配合MACD指标二次上穿,胜算应该还可以吧。这条成本线有点类似年线。选股公式如下:
              
              C>COST(50) AND C< COST(50)*1.05 AND C>REF(C,1) AND REF(C,1)<
            REF(C,2) AND "MACD.MACD"(12,26,9)>0;
              
              ◆应综合如下因素:筹码以前的分布状况,当时的换手率等。关于筹码集中度您是怎么理解的?40天的建仓时间,大庄短点,当然他要抢筹是例外。我主要不明白,您认为什么样的持仓比例,可以使庄家来拉升呢?大于62%?还有能从他的前期吸筹判断他的资金来源么,或者说是他的实力?如果上述可以办到,请问如何做?
              
              ◆把SUM换成MA,简单易懂,结果一样:
              
              B1:=MA(COST(10),A);{在A周期里获利10%的平均价}
              B2:=MA(COST(20),A);{在A周期里获利20%的平均价}
              B3:=MA(COST(30),A);{在A周期里获利30%的平均价}
              B4:=MA(COST(40),A);{在A周期里获利40%的平均价}
              B5:=MA(COST(50),A);{在A周期里获利50%的平均价}
              
              ◆价、量、势、点,是做股票的关键。楼主的分析思路中是否存在一个误区,即想象中的庄家成本区域,而称这个区域是庄家成本区似乎不是很贴切,应该就是简单的成本低位区域,而这个区域不一定要先求得换手时间后再求解成本,在求解过程中,楼主给COST(10)赋予的权重最大,而COST(50)最小,按照众数原则,不用楼主复杂的算法,一样可以估算出该庄家成本线的位置,即在COST(18)-C0ST(20),也就是简单的用SUM(COST(20),A)/A一样可以替代楼主复杂的公式,尽管楼主对每一个线段的含义明确的给予了清晰的解释,但这个解释的合理性有待商榷。而楼主思路中值得学习的是将换手率转换成时间来求解成本线。
              
              ◆公式绘出的成本线,大致在1996-2000年以前与K线趋势比较相符,而在之后相差较大。不仅在大盘指数K线上明显,在个股中也较普遍。这是必然的,还是公式上有什么偏差?好象股价在感谢对我们的支持,大家共同提高~线上方,回调不破的,后势还有上涨。但也不尽然,本来回调不下破的,自然会上涨。庄家吸筹有快有慢,成本有高有低,这里假设的是庄家在一定时期内开始或已经吸筹,庄家的成本也是偏低的。

 

 


一个很好的"筹码集中度"指标,可直接找到筹码集中度高的股票
筹码集中度:=COST(10)/(COST(80)-COST(10));

筹码1:EMA(筹码集中度,1)*10,LINETHICK2,COLOR3399ff;
筹码3:EMA(筹码集中度,3)*10,LINETHICK2,COLORRED;


筹码13:EMA(筹码集中度,13)*10,LINETHICK1;
筹码34:EMA(筹码集中度,34)*10,LINETHICK1;
筹码55:EMA(筹码集中度,55)*10,LINETHICK1;
筹码90:EMA(筹码集中度,90)*10,LINETHICK1,COLORff00ff;
筹码250:EMA(筹码集中度,250)*10,LINETHICK1,COLORblue;

指标说明:

      1、这是一个着眼于中长线选股的指标,它直观地描述了一种状态,在这种状态下介入,你不但可以抓住强庄股,而且会有很好的信心持股,从而帮你赚到最大利润。

      2、由于它仅仅使用最直接的原始数据,对这些数据并未有过多的人为加工或其他人为的解读,因此会最大程度地忠实于市场实际,在这个意义上说,它应该具有很高的可信度。

      3、使用时,每一条短周期的筹码线上穿长周期的筹码线,均是筹码收集的过程,上穿角度越大,筹码收集越快,表明有强庄位于其中。

      4、随着筹码的不断集中,筹码1、筹码3指标线不断上行直到某个阶段高点,然后突然拐头向下,而股价继续上涨,表明为主力锁仓,其后势股价常有惊人涨幅,可积极参与。

      5、使用时,应注意随时补充数据,以免影响选股判断的准确性。

      6、使用时,应结合成交量趋势、资金趋势、大盘趋势等综合判断,以提高准确率。

      7、资源共享,今将原码公布于此,希望对大家能够有所帮助,并欢迎同道进一步交流指正。

 

{筹码低位密集源码}

DRAWTEXTREL(10,10,'——北斗星大智慧'),COLOR555555;
一:=COST(10)/COST(1);
二:=COST(20)/COST(10);
三:=COST(30)/COST(20);
四:=COST(40)/COST(30);
五:=COST(50)/COST(40);

密:=一<二 AND 一<三 AND 一<四 AND 一<五 ;
密二:=二<三 AND 二<四 AND 二<五 ;
密三:=三<二 AND 三<四 AND 三<五 ;
密四:=四<二 AND 四<三 AND 四<五 ;
密五:=五<二 AND 五<三 AND 五<四 ;


STICKLINE(c>=o,c,o,9,1),colorred;
STICKLINE(c>=o,l,o,0.1,0),colorred;
STICKLINE(c>=o,c,h,0.1,0),colorred;
STICKLINE(cSTICKLINE(c

x11:POLYLINE(密二>0,COST(11)),COLOR008800;
x21:POLYLINE(密二>0,COST(12)),COLOR008800;
x31:POLYLINE(密二>0,COST(13)),COLOR008800;
x41:POLYLINE(密二>0,COST(14)),COLOR008800;
x51:POLYLINE(密二>0,COST(15)),COLOR008800;
x61:POLYLINE(密二>0,COST(16)),COLOR008800;
x71:POLYLINE(密二>0,COST(17)),COLOR008800;
x81:POLYLINE(密二>0,COST(18)),COLOR008800;
x91:POLYLINE(密二>0,COST(19)),COLOR008800;

x12:POLYLINE(密三>0,COST(21)),COLORff9933;
x22:POLYLINE(密三>0,COST(22)),COLORff9933;
x32:POLYLINE(密三>0,COST(23)),COLORff9933;
x42:POLYLINE(密三>0,COST(24)),COLORff9933;
x52:POLYLINE(密三>0,COST(25)),COLORff9933;
x62:POLYLINE(密三>0,COST(26)),COLORff9933;
x72:POLYLINE(密三>0,COST(27)),COLORff9933;
x82:POLYLINE(密三>0,COST(28)),COLORff9933;
x92:POLYLINE(密三>0,COST(29)),COLORff9933;

x13:POLYLINE(密四>0,COST(31)),COLOR008800;
x23:POLYLINE(密四>0,COST(32)),COLOR008800;
x33:POLYLINE(密四>0,COST(33)),COLOR008800;
x43:POLYLINE(密四>0,COST(34)),COLOR008800;
x53:POLYLINE(密四>0,COST(35)),COLOR008800;
x63:POLYLINE(密四>0,COST(36)),COLOR008800;
x73:POLYLINE(密四>0,COST(37)),COLOR008800;
x83:POLYLINE(密四>0,COST(38)),COLOR008800;
x93:POLYLINE(密四>0,COST(39)),COLOR008800;

x14:POLYLINE(密五>0,COST(41)),COLOR33cc00;
x24:POLYLINE(密五>0,COST(42)),COLOR33cc00;
x34:POLYLINE(密五>0,COST(43)),COLOR33cc00;
x44:POLYLINE(密五>0,COST(44)),COLOR33cc00;
x54:POLYLINE(密五>0,COST(45)),COLOR33cc00;
x64:POLYLINE(密五>0,COST(46)),COLOR33cc00;
x74:POLYLINE(密五>0,COST(47)),COLOR33cc00;
x84:POLYLINE(密五>0,COST(48)),COLOR33cc00;
x94:POLYLINE(密五>0,COST(49)),COLOR33cc00;

stickline(密>0 AND cstickline(密二>0 AND cstickline(密二>0 AND cstickline(密三>0 AND cstickline(密三>0 AND cstickline(密四>0 AND cstickline(密四>0 AND cstickline(密五>0 AND cstickline(密五>0 AND c

aa:=if(c>=ref(c,3),1,0);
bb:=if(c>=ref(c,5),1,0);
cc:=if(c>=ref(c,7),1,0);
dd:=if(c>=ref(c,8),1,0);
ee:=if(c>=ref(c,13),1,0);
ff:=if(c>=ref(c,21),1,0);
gz2:=aa+bb+cc+dd+ee+ff;
kk:=0;
for i=1 TO 4  DO
kk:=kk+REF(gz2,i);
kkk:=kk/4;
DRAWTEXT(kkk=0 and gz2>0 and c>REF(c,1),L*0.994,'↑☆-买'),COLORGREEN;
DRAWTEXT(kkk=6 and gz2<6 ,H*1.02,'卖-☆↓'),COLORRED,ALIGN2;

A:=SUMBARS(V,CAPITAL*1);
A1:=SUM(COST(10),A)/A;
A2:=SUM(COST(20),A)/A;
A3:=SUM(COST(30),A)/A;
A4:=SUM(COST(40),A)/A;
A5:=SUM(COST(50),A)/A;
庄家成本线:(5*A1+4*A2+3*A3+2*A4+A5)/15,Color98FF00,linethick2;