口腔tnm分期:通达信选股指标集-123

来源:百度文库 编辑:学校大全网 时间:2022/08/11 13:36:00

通达信选股指标集

分类: 技术指标 2009-02-13 16:19

{暴裂旋风 }
Var1:=ABS(HIGH-LOW);
SUM(Var1,7)/CLOSE>0.5 AND SUM(Var1,7)/CLOSE<0.8 AND CLOSE>7 AND CLOSE<11;

{带量突破 }
Var1:=EMA(COST(80),10);
COUNT(CROSS(CLOSE,Var1),2)>=1 AND VOL/CAPITAL>=0.1;

{攻击箱顶 }
Var1:=HHV(MA((LOW+HIGH+CLOSE+OPEN)/4,5),58);
BETWEEN(CLOSE,Var1*1.001,Var1) AND REF(Var1,3)=Var1 AND VOL>REF(VOL,2);

{勾头向上 }
Var1:=EMA(CLOSE,5);
Var2:=REF(Var1,1);
Var3:=REF(Var2,1);
Var1>Var2 AND Var2>Var3;
{股价趋势线勾头向上}

{果断介入}
Var1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
Var2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
Var3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
Var4:=(Var1+2*Var2+3*Var3)/6;
Var5:=MA(Var4,3)-STD(Var4,3);
Var6:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
Var7:=SMA(Var6,3,1);
Var8:=SMA(Var7,3,1);
Var9:=3*Var7-2*Var8;
CROSS(Var9,Var8) AND COUNT(Var5<-12 AND Var5>-14,3)>=1;

{横盘是银}
Var1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
Var2:=SMA(Var1,3,1);
Var3:=SMA(Var2,3,1);
Var4:=EMA(CLOSE,12)-EMA(CLOSE,26);
Var5:=EMA(Var4,9);
Var6:=2*(Var4-Var5);
COUNT(CROSS(Var2,Var3),2)>=1 AND COUNT(CROSS(Var6,0),5)>=1 AND MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,20) AND CLOSE>MA(CLOSE,5);
{“短线是银”的使用说明:
此组合选择比较简单,初学者易于掌握,短线有一定可操作性与准确性。但只适合于3天内的短线炒作,不能确定长期趋势。
选股设置:
2日内KD金叉,5日内MACD金叉,均线5日,10日,20日多头排列,收盘价涨过5日均线。}

{蛟龙出宫}
Var1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
蛟龙出宫: CROSS(Var1,MA(Var1,10)) AND Var1<35;

{抄底绝招 N(1,30,22)N2(1,10,5)N3(1,5,3)N4(-50,0,-30)}
Var2:=CLOSE<0.98*REF(CLOSE,1);
Var3:=OPENVar4:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
Var5:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
Var6:=MA(COST(N)/LOW,N3);
Var7:=Var6>1.5 AND Var4>N2 AND Var5Var7 AND (COUNT(Var7,10) AND Var2 OR COUNT(Var7,20) AND Var3);

{一阳穿三线 n:1 100 5 n1:1 100 10n2:1 100 30}
count(cross(c,ma(c,n)) and cross(c,ma(c,n1)) and cross(c,ma(c,n2)),1) ;

{未来星}
骚动:=(EMA(WINNER(CLOSE),7)-EMA(WINNER(CLOSE),35))*5;
未来:=EMA(CLOSE,7)-EMA(CLOSE,21);
{解脱:=EMA(CLOSE/REF(HHV(CLOSE,7),50),1);}
cross(骚动,未来) and 骚动>=ref(ma(骚动,未来),1);
{未来之星改编}

{放量反转}
VAR1:=VOLREF(VOL,3)>REF(VOL,4);
VAR2:=CLOSE>REF(CLOSE,1)>REF(CLOSE,2)放量反转:VAR1 AND VAR2 and ma(close,5);

{波段王抄底}{结合波段王指标}
趋势线:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
CROSS(趋势线,10) and 趋势线>=ref(ma(趋势线,10),1);

{出手就赢}{结合波段王}
RSV9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K1:=SMA(RSV9,3,1);
DK1:=K1-REF(K1,1);
出手就赢:=IF(DK1>7 AND REF(DK1,1)<0 AND (DK1-REF(DK1,1))>9,50,0);
出手赢:(出手就赢>0);

{稳赢剑抄底 n:1 100 12}
Var1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
Var2:=SMA(Var1,3,1);
Var3:=SMA(Var2,3,1);
Var4:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
Var5:=CROSS(Var4,10) AND Var3抄底:Var5
{结合稳赢剑指标使用}

{百万买入}
趋势线:=(((3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1))-50)*(1.032)+50);
CROSS(趋势线,21);
{结合百万精品用}

{龙行短线选股}
RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
短K:=SMA(RSV,3,1);
短D:=SMA(短K,3,1);
cross(短K,短D)
{配合龙行kdj指标使用}

{放量拉升}
底部吸筹指标:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;
IF(CROSS(底部吸筹指标,-5.4),(8+底部吸筹指标)*10,0);
{结合底部吸筹指标使用}

{稳健追涨选股}
MA1:=EMA(CLOSE,5);
MA2:=EMA(CLOSE,10);
MA3:=EMA(CLOSE,20);
MA4:=EMA(CLOSE,30);
MA5:=EMA(CLOSE,60);
Var1:=MAX(MA1,MAX(MA2,MAX(MA3,MA4)));
Var2:=MIN(MA1,MIN(MA2,MIN(MA3,MA4)));
Var3:=(Var1-Var2)/Var2*1000;
Var4:=MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1) AND MA4>REF(MA4,1) AND MA5>REF(MA5,1);
Var5:=Var3<5;
Var6:=COUNT(Var5=1,5)>0;
Var7:=CROSS(MA1,MA4);
Var8:=Var4 AND Var6 AND Var7;
Var8
{结合稳健追涨主图指标使用}

{领头羊选股}
白色:=SMA(HIGH,21,2)*1.05,;
黄色:=SMA(LOW,21,2)*0.95;
粉色:=SMA(LOW,5,1);
绿色:=SMA(CLOSE,2,1),;
波段买入:=IF(CROSS(绿色,粉色),白色*1.05,粉色);
领头羊:=IF(CROSS(绿色,白色),白色*1.10,黄色);
领头羊>黄色 or 波段买入>粉色
{ 绿线上穿紫线时,可作波段买入,绿线上穿白线时很可能是大牛股。
可作为预警选股公式}
{结合寻找领头羊指标使用}

{猎庄}
Var2:=(CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100;
Var3:=SMA(Var2,20,1);
Var4:=SMA(Var3,15,1);
猎庄:=Var3-Var4;
多空分界:=1;
cross(猎庄,多空分界) and 猎庄>=ref(ma(猎庄,多空分界),1);

{中短波选股}
HZ:=eMA(CLOSE,13);
短波:=EMA(hz,1);
中波:=ema(hz,26);
均线148天:=EMA(C,148);
成本:=SUM(AMOUNT,0)/SUM(VOL,0)/100;
HZ2:=ema(hz,8);
cross(短波,HZ2);
{结合中短波主图使用}


{超跌买点}
a1:=(CLOSE-MA(CLOSE,10))/MA(CLOSE,10)*100;
a2:=a1>ref(a1,1);
a1<-0.18 and a2;

{缺口回补}
v1:=BARSLAST(l>ref(h,1) and c/o>1.05);
l

{天堂星踏金浪1}
VarC:=(2*CLOSE+HIGH+LOW)/4;
VarD:=LLV(LOW,34);
VarE:=HHV(HIGH,34);
VarF:=LLV(LOW,13);
Var10:=HHV(HIGH,13);
Var11:=EMA((VarC-VarF)/(Var10-VarD)*100,5);
Var12:=EMA((VarC-VarD)/(VarE-Vard)*100,8);
金浪:= Var11;
aa:=ema(var11,7);
海浪:= Var12;
if(cross(金浪,aa) and aa<=25 ,1,0);

{来抢钱吧}
var1:=88;
var2:=68;
var3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
var4:=SMA(var3,3,1);
var5:=SMA(var4,3,1);
var6:=3*var4-2*var5;
var7:=SMA(CLOSE/HHV(HIGH,120),3,1)*100;
var7<68 AND BARSLAST(CROSS(var2,var7))>2 AND var5<30 AND CROSS(var6,var5);

{起攀选股}
VAR6:=(2*C+H+L)/4;
VAR7:=LLV(L,27);
VAR8:=HHV(H,27);
攀登:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13)-50;
金山:=EMA(0.618*REF(攀登,1)+0.382*攀登,3);
起攀:cross(攀登,金山) and c/ref(c,1)>1.02; 
{根据起攀图指标改编,这是精简后的指标}

{波段底部}
YTC1:=LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.02;
底部吸筹指标:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100*YTC1, ;
波段底部:IF(CROSS(底部吸筹指标,-24),0,15)*YTC1;

{黑马起步}
A1:=VOL=HHV(VOL,120);
A2:=CLOSE/OPEN>1.05;
TJ:=A1 AND A2;
TJ AND (REF(BARSLAST(TJ),1)>80 OR BARSSINCE(TJ)=0);

{黑马摇篮之大黑马}
ss1:=(LOW+HIGH+CLOSE*2)/4;
ss2:= MA(ss1,4);
ss3:=HHV(ss2,10);
ss4:=ma(ss3,3);
ss5:=1.25*ss4-0.25*ss3;
xkkj:=if(ss5>ss3,ss3,ss5);
ff1:=LLV(ss2,10);
ff2:=ma(ff1,3);
ff3:=1.25*ff2-0.25*ff1;
dkkj:=if(ff3ma13:=ma(c,13);
zdhm:=cross(c,dkkj) and cross(c,ma13) and cross(c,xkkj);
zhm:=cross(c,ma13) and cross(c,xkkj);
大黑马:zdhm or zhm;

{黑马摇篮之小黑马}
a:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*a+19*REF(a,1)+18*REF(a,2)+17*REF(a,3)+16*REF(a,4)+15*REF(a,5)+14*REF(a,6)
+13*REF(a,7)+12*REF(a,8)+11*REF(a,9)+10*REF(a,10)+9*REF(a,11)+8*REF(a,12)
+7*REF(a,13)+6*REF(a,14)+5*REF(a,15)+4*REF(a,16)+3*REF(a,17)+2*REF(a,18)+
REF(a,20))/211;
D2:=EMA(D1,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
小黑马:CROSS(D1,K1);

{短线套利选股]
ma6:=ma(c,6);
ma18:=ma(c,18);
买进价:=((c-ref(ma6,1))/6+ma6)*1.004;
白买进:=cross(c,买进价) and 买进价>ref(买进价,1);
加码价:=((c-ref(ma18,1))/18+ma18)*1.004;
黄加码:=cross(c,加码价) and 加码价>ref(加码价,1);
白买进 or 黄加码;

运用概率选股票
  需要说明的是,运用概率选股确实是笔者短线操作的炒股心得。下面我将两种方法详细介绍给大家,以求相互交流共同提高。
  第一种方法笔者称之为“两涨一缩”,也即股价两日连续上涨而成交量出现萎缩。在某股票软件的智能选股系统设置条件如下:(1)5、10、20、30日均线多头排列;(2)股价连续两天上涨;(3)K线连续两天收阳线;(4)今天的成交量小于昨天的成交量,此种情况连续两天出现。应该指出的是,在选出股票的当天其成交量越萎缩得厉害越佳。如果在下一个交易日该股再次缩量收出一根实体较小的小阴线或十字星,尾盘即是投资者的介入良机。投资者可以打开K线图看看,在今年的行情中许多股票的上涨中继均走出了上述图形。有例为证。今年4月14日,笔者根据设置的条件选出了G航通。当天G航通的均线系统呈现多头排列,股价上涨3.77%,高于前一交易日3.44%的涨幅,成交量只有前一交易日的58%,为典型的缩量上涨形态。15日,G航通缩量下跌2.14%,尾盘时笔者大胆买入。4月26日,笔者用同样的方法选出了G苏长电,27日尾盘介入,该股三个交易日涨幅达到了10%。
  第二种方法为“大幅缩量法”。笔者设置的条件为:今天的成交量小于昨天的成交量,且今天的成交量低于昨天成交量的40%。在行情的初期,不少股票在大幅放量之后突然缩量,介入的资金要想出局当然是不可能的,那么就只有一种可能:主力在清洗筹码。今年3月28日,G美克在前几个交易日放量之后大幅缩量,当天成交量不到前一交易日的28%,29日继续缩量,笔者尾盘果断介入,取得了不错的收益。另外,我们还可以来看看G格力在2005年12月16、17日这两天的成交量及其后的走势,相信这种方法对投资者会有所启示。
  运用概率选股的方法免去了从一千多只股票中进行挑选的麻烦,面宽点多,简单明了。当然,就如笔者在上文所说的,技术选股只能做参考,基本功课还是要做的。
  根据原文编写的选股指标:
两涨一缩
A1:=MA(CLOSE,5);
A2:=MA(CLOSE,10);
A3:=MA(CLOSE,20);
A4:=MA(CLOSE,30);
A5:=COUNT(A1> A2 AND A2> A3 AND A3> A4,3)=3 AND CLOSE> OPEN;
A6:=COUNT(C> REF(C,1),2)=2;
A7:=COUNT(C> O,2)=2;
A8:=COUNT(VOL< REF(VOL,1),2)=2;
A5 AND A6 AND A7 AND A8;

大幅缩量
REF(C> O,1) AND VOL< REF(VOL,1) AND VOL/REF(VOL,1)< 40/100;

{黑马绝技选股}
EMA13:=EMA(C,13);
EMA30:=EMA(C,30);
EMA60:=EMA(C,60);
EMA90:=EMA(C,90);
EMA120:=EMA(C,120);
EMA250:=EMA(C,250);
F1:=EMA30-EMA60<130/1000 AND EMA30-EMA90<230/1000 AND EMA30-EMA120<330/1000;
F2:=EMA60-EMA30<130/1000 AND EMA60-EMA90<230/1000 AND EMA60-EMA120<330/1000;
F3:=EMA90-EMA30<130/1000 AND EMA90-EMA60<230/1000 AND EMA90-EMA120<330/1000;
F4:=EMA120-EMA30<130/1000 AND EMA120-EMA60<230/1000 AND EMA120-EMA90<330/1000;
F5:=EMA30-EMA60<100/1000 AND EMA30-EMA90<200/1000;
FF1:=F1 AND F2 AND F3 AND F4 AND CROSS(EMA30,EMA60);
FF2:=F1 AND F2 AND F3 AND F4 AND CROSS(EMA(C,13),EMA30);
FF3:=F5 AND C>EMA250 AND CROSS(EMA30,EMA60);
G1:=EMA60-EMA90<220/1000 AND EMA60-EMA120<320/1000 AND EMA60-EMA250<420/1000;
G2:=EMA90-EMA30<220/1000 AND EMA90-EMA60<320/1000 AND EMA90-EMA250<420/1000;
G3:=EMA120-EMA60<220/1000 AND EMA120-EMA90<320/1000 AND EMA120-EMA250<420/1000;
G4:=EMA250-EMA60<220/1000 AND EMA250-EMA90<320/1000 AND EMA250-EMA120<420/1000;
GG1:=G1 AND G2 AND G3 AND G4 AND CROSS(EMA13,EMA30);
GG2:=G1 AND G2 AND G3 AND G4 AND CROSS(EMA30,EMA60);
FF1 OR FF2 OR FF3 OR GG1 OR GG2;