古代特洛伊兽:帝纳波利交易法全套指标——里弄胡同——东方财富网博客

来源:百度文库 编辑:学校大全网 时间:2021/11/28 10:37:33
帝纳波利交易法全套指标(2010-05-14 12:10:06)分类:证券

XDMA(置换移动平均线)——主图指标:
上唇:REF(SMA(C,3,1),3),COLORGREEN,LINETHICK1;
牙齿:REF(SMA(C,7,1),5),COLORRED,LINETHICK2,CROSSDOT;
下颚:REF(SMA(C,25,1),5),COLORBLUE,LINETHICK2;

XMACD(MACD)——附图指标:
AA:MA(C,8)-MA(C,17);
BB:MA(AA,9);

XMP(MACD指标预测器)——附图指标:

AA:=MA(C,7);
BB:=MA(C,16);
CC:=MA(C,8)-MA(C,17);
DD:=MA(CC,8);
DMP:17*(8/9*REF(DD,1)-7/9*REF(AA,1)+128/153*REF(BB,1));
收盘:C;

【上面的MACD和MACD指标预测器是MA版的,
下面是EMA版的,推荐用下面的版本:

XMACD(MACD)——附图指标:
AA:EMA(C,8)-EMA(C,17);
MACD:EMA(AA,9);

XMP(MACD指标预测器)——主图指标:

AA:=EMA(C,8);
BB:=EMA(C,17);
CC:=EMA(AA-BB,9);
XMP:9*REF(CC,1)-7*REF(AA,1)+8*REF(BB,1);



XKD(修正kd指标)随机指标——附图指标:
RSV:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:SMA(RSV,3,1);
D:SMA(K,3,1);

DTO(去趋势摆荡指标)——附图指标:
DTO:C-MA(C,7);
UP:HHV(AA,60);
DWLV(AA,60);
ZZ:0;

DOP(去趋势指标预测器)——主图指标:
AA:=C-MA(C,7);
UP:=HHV(AA,60);
DW:=LLV(AA,60);
DOPU:7/6*UP*0.9+REF(MA(C,6),1),LINETHICK1;
DOPD:7/6*DW*0.9+REF(MA(C,6),1),LINETHICK1;

出了指标外,老帝还有几个方向性信号,其实是趋势转折的信号,主要是:
1:双底结构(包括双重穿透。双重穿透失败,面包加黄油);
2:头肩顶失败;
3:三角形失败;
4:火车轨道(其实是高位的并列大阳阴或低位的并列大阴阳的K线组合)。

DTO(去趋势摆荡指标)——附图指标:
DTO:C-MA(C,7);
UP:HHV(AA,60);
DW: LLV(AA,60);
ZZ:0;

【飞狐系列帝式指标】
1.三条置换移动平均线【主图】

D3X3:ma(c,3),SHIFT3,COLORCYAN;
D7X5:ma(c,7),SHIFT5,COLORCYAN;
D25X5:ma(c,25),SHIFT5,COLORCYAN;

2.macd

Fast: eMA(close,8.3896) - eMA(close,17.5185),colorred;
Slow: eMA(fast,9.0503),COLORCYAN;
drawicon(cross(fast,slow),fast,5);
PARTLINE(1>0,0);

3.随机指标

RSV:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:SMA(RSV,3,1),colorred;
D:SMA(K,3,1),COLORCYAN;
drawicon(cross(k,d) and k<20,d,7);

4.超买超卖

C-ma(C,7),colorwhite;

5.摆动指标预测器(DOP)【主图】

DMA3X3:ma(c,3),SHIFT3,COLORMAGENTA;
INPUT.:N(135,1,250);
v1:=C-ma(C,7);
vv:=v1;
e:=SORT(vv,0,datacount-N,DATACOUNT);

smax:=(vv[datacount-1+1]+vv[datacount-2+1]+vv[datacount-3+1])/3;
smin:=(vv[datacount-135+1]+vv[datacount-134+1]+vv[datacount-133+1])/3;
超买价:smax*7/6+ma(c,6),shift1,COLORCYAN;
超卖价:smin*7/6+ma(c,6),shift1,COLORCYAN;

DRAWICON(high>超买价,high*1.01,7);
DRAWICON(low<超卖价,low*0.99,6);
drawtext(barpos=SYSPARAM(2),sysparam(5),'\\ 明日 超买价: '+numtostr(超买价,2)),colorgreen,PXUP75;
drawtext(barpos=SYSPARAM(2),sysparam(5),'\\ \\ \\ 明日 超卖价: '+numtostr(超卖价,2)),colorgreen,PXUP75;
drawtext(barpos=SYSPARAM(2),sysparam(5),'\\ \\ \\ \\ \\ 明日 DMA3x3: '+numtostr(ref(DMA3X3,2),2)),colorgreen,PXUP75;


6.MACD预测器(DMP)【主图】

// dinapoli macd

bb:=close;
ema08[1]:=bb[1];
ema17[1]:=bb[1];
fast[1]:=0;
slow[1]:=0;
for i=2 to datacount do
begin
ema08[i]:=(bb[i]*2+ ema08[i-1]*7.3896)/9.3896; // ema(x:single, n:single)
ema17[i]:=(bb[i]*2+ ema17[i-1]*16.5185)/18.5185;
Fast[i]:=ema08[i]-ema17[i],colorred;
Slow[i]:=(fast[i]*2+ slow[i-1]*(8.0503))/(10.0503),COLORCYAN;
end;

// dmp
dmp: (18.5185*9.3896*slow + ema17*9.3896*16.5185 - ema08* 18.5185*7.3896 )/18.2578,colorred,shift01; // 18.2578 = 2*(17.5185-8.3896);
DRAWNUMBER(ISLASTBAR,dmp,dmp,2),colored;

7、帝式DSP随机指标【主图】
RS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
KSMA:=SMA(RS,3,1);
DSMA:=SMA(KSMA,3,1);
F:=HHV(HIGH,8)-LLV(LOW,8);
DSP:((DSMA*3-KSMA*2)*F/100+LLV(LOW,8)),SHIFT1,linethick1,colorgreen;
PARTLINE(CLOSE>REF(DSP,1),REF(DSP,1)),LINETHICK1,colorFF;

黄金线飞狐系统
手工录入参数——n/1/100/34

MM1:=EMA(C,3);
MM2:=EMA(C,25);

D3×3:MM1,shift3,COLORC08000,LINETHICK1;
D25×5:MM2,shift5,COLORRED,LINETHICK1;

A1:=HHV(HIGH,N);
A2:=LLV(LOW,N);
A3:=(A1-A2)*0.618+A2;
A4:=(A1-A2)*0.5+A2;
A5:=(A1-A2)*0.382+A2;
PD:=ISLASTBAR;
最高:A1,COLORFF8080;
最低:A2,COLORFF8080;
F3:A3,COLOR808080,LINEDOT;
F4:A4,COLOR808080,LINEDOT;
F5:A5,COLOR808080,LINEDOT;

DRAWNUMBER(PD,最高,最高,2),COLORFF8080,ALIGN0;
DRAWNUMBER(PD,最低,最低,2),COLORFF8080,ALIGN0;
DRAWNUMBER(PD,F3,F3,2),COLOR808080,ALIGN0;
DRAWNUMBER(PD,F4,F4,2),COLOR808080,ALIGN0;
DRAWNUMBER(PD,F5,F5,2),COLOR808080,ALIGN0;

帝纳波利交易法全套指标——里弄胡同——东方财富网博客 波神规律三十六句操盘口诀(新版)——里弄胡同——东方财富网博客 指标均线技巧——股虫——东方财富网博客. 指标均线技巧——股虫——东方财富网博客a 通达信虚拟成交量指标延伸——轻松赢利——东方财富网博客 指标均线——股虫——东方财富网博客 收藏几个《通达信》指标公式——信心 耐心 等待 ——东方财富网博客 指标均线技巧1——股虫——东方财富网博客 指标均线技巧——股虫——东方财富网博客! 通达信MACD背驰指标——飘红——东方财富网博客 指标均线技巧——股虫——东方财富网博客1 大智慧一剑封喉指标源码——哲别——东方财富网博客 指标均线技巧——股虫——东方财富网博客3 分时指标公式——天道酬勤——东方财富网博客 指标均线技巧——股虫——东方财富网博客 指标均线技巧——股虫——东方财富网博客安安 量比指标在实战中的运用——股虫——东方财富网博客 通达信分时指标公式--高抛低吸的秘密武器——东方财富网博客 齐峰芝——东方财富网博客 忠言——东方财富网博客 学会找指标共振——,东方财富网博... 一个极好的当天低买高卖CDP指标——太极股道的博客——东方财富网博客 成交量——才是真正的王者指标(转载)——金股圣手——东方财富网博客 教你一招:基础面选股最重要的三个指标——沧桑战神——东方财富网博客